Firefox Quantum |OT| - Ground up redesign with new speed engine, UI, & extensions

Santerestil

The Fallen
Oct 28, 2017
365
58.0.2 has broken video playback for me: all the .mp4 files, including .gifv, and many Youtube videos, show only a mess of green/purple/blue bars, even if soud is okay.
Somebody know how to resolve this?
 

Ruken

Member
Oct 29, 2017
59
Is there a replacement for Text-To-Image, AKA something that turns image URLs into thumbnails? I like having it on when I browse reddit.
 

Psychotext

Member
Oct 30, 2017
3,851
Firefox seems fucked for me today. A lot of my tabs are loading blank, and sometimes when I switch tab the page that was there doesn't display (the current tab remains displayed).
 

gagewood

Member
Oct 25, 2017
739
I installed Enhanced Steam a few days ago and everything was working well for a couple days. However, since Tuesday whenever I visit the Steam store the page lags significantly and my CPU usage increases to 70% or more. Disabling ES resolves the issue, but I can't seem to figure out if it's a particular setting in ES or in FF. Even stranger is that everything was fine for 2-3 days before that. I tried clearing the ES cache but that didn't work. I'm not sure what else the problem could be. Has anyone else run into this?
 

AYZON

Member
Oct 29, 2017
389
Germany
Its been a while, I assume people have figured out why embedded stuff doesnt work in firefox by now?
Neither images nor Twitter is working for me and hasnt since I switched over to firefox a couple months ago.
 

ody

Community Resettler
Member
Oct 25, 2017
10,907
Its been a while, I assume people have figured out why embedded stuff doesnt work in firefox by now?
Neither images nor Twitter is working for me and hasnt since I switched over to firefox a couple months ago.
add-on or tracking protection? what do embeds look like to you?
 

AYZON

Member
Oct 29, 2017
389
Germany
embedded images will just show IMG tags and twitter embeds will show a "Loading tweet..." hyperlink

Edit: The only plugin that im running that could potentially mess up websites is ublock and even without it nothing works.
 
Last edited:

shockdude

Member
Oct 26, 2017
659
embedded images will just show IMG tags and twitter embeds will show a "Loading tweet..." hyperlink

Edit: The only plugin that im running that could potentially mess up websites is ublock and even without it nothing works.
That sounds like Firefox's tracking protection. Visit the Firefox Options > Privacy & Security, set Tracking Protection to Only Private Windows or Off.
 

AYZON

Member
Oct 29, 2017
389
Germany
oh yea that did work, but since so far resetera has been the only site where I had issues with it, would it be possible to add it to a whitelist? I mean there is apparently one but I cant add anything to it.
 

Jucksalbe

User requested ban
Banned
Oct 27, 2017
739
oh yea that did work, but since so far resetera has been the only site where I had issues with it, would it be possible to add it to a whitelist? I mean there is apparently one but I cant add anything to it.
Just look at the address bar and click on that little shield icon.
 

ody

Community Resettler
Member
Oct 25, 2017
10,907
You shouldn't need Firefox's Tracking Protection if you have uBlock Origin installed. Try enabling the 3 filter lists under "Privacy" in uBO's dashboard and check if the problem persists.
 

AYZON

Member
Oct 29, 2017
389
Germany
Just look at the address bar and click on that little shield icon.
There isn't a shield icon or anything close to it. But:
You shouldn't need Firefox's Tracking Protection if you have uBlock Origin installed. Try enabling the 3 filter lists under "Privacy" in uBO's dashboard and check if the problem persists.
If Ublock stops tracking anyways, that is a none issue I suppose.
Thanks guys.
 
Oct 29, 2017
609
I went to go to Homestar Runner the other day to find out that there's seemingly zero flash support, even legacy in FF now? Is there a way to toggle it on to get my Strong Bad fix?
 

Nikus

Avenger
Oct 25, 2017
3,471
France
I keep having a new tab who opens randomly for Firefox AddonBrowser, is it a legit thing ? It's not in my addons or plugins, I can't find it. And I've been having warnings from Avast since it started to pop up. I've reverted Firefox to its default settings but it didn't help. I'm gonna uninstall it completely and reinstall but I doubt it will do anything.
 

woo

Member
Nov 11, 2017
671
Super herpy derpy noob question [even though I have used Firefox, off and on for years] :/ how do I use the keyboard shortcuts in the right click menu e.g. 'Save Link As' ? What combination of buttons + the underlined letter [in this case, k] do I need to press?
 

Psychotext

Member
Oct 30, 2017
3,851
So fucking annoyed that xmarks still isn't working. Firefox sync has once again completely fucked up my bookmarks (basically fails to delete on my second machine, then takes those bookmarks that should be deleted and moves them over to my main machine).

Is there really nothing else I can use to handle synchronising? It's massively frustrating.
 

pestul

Member
Oct 25, 2017
540
Firefox 58.02 cpu spikes like crazy for me.. I just deleted my profile and reinstalled and I still see random 50-100% cpu usage spikes and general high usage even with only 2 tabs open. Is anyone else getting this? Two tabs open, 1.4GB of ram used and high cpu. Generally laggy performance all around.
 

shockdude

Member
Oct 26, 2017
659
Firefox 58.02 cpu spikes like crazy for me.. I just deleted my profile and reinstalled and I still see random 50-100% cpu usage spikes and general high usage even with only 2 tabs open. Is anyone else getting this? Two tabs open, 1.4GB of ram used and high cpu. Generally laggy performance all around.
That's odd. Type "about:performance" in the address bar to see Firefox's memory usage and each tab's CPU usage.
 

pestul

Member
Oct 25, 2017
540
That's odd. Type "about:performance" in the address bar to see Firefox's memory usage and each tab's CPU usage.
All of my Resetera tabs say "may currently be slowing down firefox". This tab alone is using 19% cpu usage.. I think it's only happening on Resetera. I also noticed a lot of constant loading happening in the bottom of the pages. Google syndication etc.. just flashing on and off loading.
 

shockdude

Member
Oct 26, 2017
659
All of my Resetera tabs say "may currently be slowing down firefox". This tab alone is using 19% cpu usage.. I think it's only happening on Resetera. I also noticed a lot of constant loading happening in the bottom of the pages. Google syndication etc.. just flashing on and off loading.
Possibly a misbehaving ad, or worse a crypto miner? Try an ad-blocker or miner-blocker and see if the CPU usage goes away. If it does, you'll want to report it to an admin.
 

pestul

Member
Oct 25, 2017
540
Possibly a misbehaving ad, or worse a crypto miner? Try an ad-blocker or miner-blocker and see if the CPU usage goes away. If it does, you'll want to report it to an admin.
Thanks uBlock Origin eliminated the problem. I checked out the log and it was blocking tons of things from Twitter mostly. I think it was something misbehaving on the site end.
 

pestul

Member
Oct 25, 2017
540
syndication.twitter.com <-- it seems pages that have embedded tweets are triggering the cpu/memory usage. And they keep loading persistently.

Here's an example from the Super Smash Bros. reveal thread. uBlock reports about 26 blocked entries and the Twitter embeds are not effected:

That's over the span of 13 seconds and includes scrolling up and down the page. I'll report that to the admins, unless it's just a firefox bug. Maybe Twitter has decided to join the Crypto foray :P
 

BriareosGAF

Member
Oct 28, 2017
731
I think issues like that are mostly reported in the funding thread.

I've had some issues recently with twitch video performance; despite reporting it's using the hardware codec, seeing significant cpu perf on ff and chrome, but not safari, which makes the developer in me suspicious that apple is providing alternate browsers with sub performant codecs. Either way it's draining battery at a pretty shocking rate, dropping frames, etc. New to recent release too. It's so hard to go through bugzilla though and figure out which of a billion reports in various states of regression/validation are a dupe or not.
 

Audioboxer

Member
Oct 25, 2017
13,828
They need to get working on their mobile browser tbh. I keep switching back to FF on the PC, but Chrome mobile just destroys it.
 
OP
OP
Vanillalite

Vanillalite

The Fallen
Oct 25, 2017
3,246
They need to get working on their mobile browser tbh. I keep switching back to FF on the PC, but Chrome mobile just destroys it.
In theory that should start with FF 60 on mobile. YMMV tho as desktop obviously appears to be the main focus.

Honestly Stylo won't be as big of a deal on mobile. It's the Web Render that we really want, and that's not out on anything yet.
 
OP
OP
Vanillalite

Vanillalite

The Fallen
Oct 25, 2017
3,246
FireFox 59 is a go.

Stable release is on the FTP. It'll be pushed to all current users tomorrow March 13th through the usual update.
 

ody

Community Resettler
Member
Oct 25, 2017
10,907
Is Firefox Android slow and crash-prone for anyone else? I force myself to use it over Chrome, but Chrome is so much faster.
Yeah its not great, but changes are coming to address speed and such. I've been using Samsung Internet (based on Chromium I believe) and it supports adblocking. Brave is another I used, but its a bit buggy.
 

CyrilFiggis

Member
Nov 3, 2017
667
Pennsylvania
Is Firefox Android slow and crash-prone for anyone else? I force myself to use it over Chrome, but Chrome is so much faster.
Yeah, it's slower and I do get random crashes, particularly on GameFAQs. I put up with it because F Chrome but it is annoying.
Also have a problem with most videos & GIFs not playing correctly. They play all jumbled and in black and white so they are pretty much un-viewable. I thought the most recent update would help but it doesn't. My phone is old AF, though (GS3), so maybe that has something to do with it.
 

Rushersauce

Member
Oct 25, 2017
2,007
One thing I've started to notice, is the video stutter/freeze that happen when you switch tabs. It's annoying as FUCK.
 

cameron

The Fallen
Oct 26, 2017
5,860
I get this weird rendering issue with 59.0.0 x64 on W10. Same with 59.0.1.



A workaround is to disable hardware acceleration or zoom to something other than 100%. Bleh.
 

cameron

The Fallen
Oct 26, 2017
5,860
^ No luck with a reset. Also tried a full reinstall (uninstalled and deleted all mozilla folders in user data) to no effect. I'm not using any extensions / add-ons either.



Edit: Stumbled across the bugzilla thread: https://bugzilla.mozilla.org/show_bug.cgi?id=1435472

Looks like a ClearType issue. If you have it off in W10, then the rendering bugs appear.

A temp fix without having ClearType on is setting the integer value of gfx.font_rendering.cleartype_params.rendering_mode to 1.
 
Last edited: