• To celebrate the release of Halo: The Master Chief Collection on Steam, Xbox Games Studios has provided 5 Steam copies of the game and 5 Xbox One copies of the game! We will be giving these away in the Gaming Giveaways |OT|. Some Steam copies will also be given away to the PC Gaming Era community.
  • An old favorite feature returns: Q&ERA is back! This time we'll be collecting questions for Remedy Entertainment, makers of Max Payne, Alan Wake, Quantum Break, and Control. Members can submit questions for the next 3 days, 4 hours, 15 minutes, 59 seconds. Submissions will close on Dec 12, 2019 at 12:00 AM.

Firefox Quantum |OT| - Ground up redesign with new speed engine, UI, & extensions

2n2

Member
Oct 25, 2017
3,458
Anyone having issues with the latest version with the May Windows 10 update?

I just updated Windows and have been having random connectivity issues and Firefox locking up.

edit: there's a new Firefox update which might have fixed it for me.
 
Last edited:

Sagitario

Member
Oct 26, 2017
680
I have a question, is there a way to stop Firefox from saving images from Twitter as name.jpg_orig?
That's a Twitter thing. It's the same for Chrome. It means it's displaying the original image and not a compressed one. You just need to edit the (or write a new) extension when you're a saving the picture (from ".jpg_orig" to just ".jpg").
 

Skyfireblaze

Member
Oct 25, 2017
4,841
That's a Twitter thing. It's the same for Chrome. It means it's displaying the original image and not a compressed one. You just need to edit the (or write a new) extension when you're a saving the picture (from ".jpg_orig" to just ".jpg").
Yeah I'm aware of the underlying cause but it's kind a bit of a bummer as I use an addon that enables me to save images to different kind of folders on the fly and sadly this keeps the _orig so I have to go into the folder afterwards and remove them manually. I hoped there would be an addon that truncates the _orig automatically.
 

Pixieking

Member
Oct 25, 2017
4,717
Yeah I'm aware of the underlying cause but it's kind a bit of a bummer as I use an addon that enables me to save images to different kind of folders on the fly and sadly this keeps the _orig so I have to go into the folder afterwards and remove them manually. I hoped there would be an addon that truncates the _orig automatically.
Don't know of an addon, but you could download Advanced Renamer and set-up a Replace rule - Text To Be Replaced ".jpg_orig", Replace With ".jpg" would work, I imagine. Still a bit of hassle, but streamlines the process a little.
 

Sejanoz

Member
Nov 10, 2017
793
Yeah I'm aware of the underlying cause but it's kind a bit of a bummer as I use an addon that enables me to save images to different kind of folders on the fly and sadly this keeps the _orig so I have to go into the folder afterwards and remove them manually. I hoped there would be an addon that truncates the _orig automatically.
Dunno if it's the same issue, but some time ago my pc suddenly started saving jpgs as .jfif (which I believe is the same format in which it saves those "jpg:orig" photos from Twitter, because I remember trying to save some hi-res pics from Twitter a while back and seeing this weird extension)

I solved the problem by doing what's mentioned in the OP here. Now that I read your post I tried saving a jpg:orig photo from Twitter and it saved it as a jpg without the "orig". It's worth a try
 

Skyfireblaze

Member
Oct 25, 2017
4,841
Don't know of an addon, but you could download Advanced Renamer and set-up a Replace rule - Text To Be Replaced ".jpg_orig", Replace With ".jpg" would work, I imagine. Still a bit of hassle, but streamlines the process a little.
Dunno if it's the same issue, but some time ago my pc suddenly started saving jpgs as .jfif (which I believe is the same format in which it saves those "jpg:orig" photos from Twitter, because I remember trying to save some hi-res pics from Twitter a while back and seeing this weird extension)

I solved the problem by doing what's mentioned in the OP here. Now that I read your post I tried saving a jpg:orig photo from Twitter and it saved it as a jpg without the "orig". It's worth a try
Thanks for the help! Unfortunately the .jfif fix didn't help in my case but it's interesting that I had this flaw in my registry aswell. I'll look into Advanced Renamer tomorrow!
 

Static_Void

Member
Oct 30, 2018
3,410
north of the Dreamlands
Are... are the new Firefox update release notes blank for anyone else?
I can see them here: https://www.mozilla.org/en-US/firefox/67.0.3/releasenotes/

Seems to be exclusively a security fix.

CVE-2019-11707: Type confusion in Array.pop
Reporter: Samuel Groß of Google Project Zero, Coinbase Security

Impact: critical

Description:

A type confusion vulnerability can occur when manipulating JavaScript objects due to issues in Array.pop. This can allow for an exploitable crash. We are aware of targeted attacks in the wild abusing this flaw.

References:


EDIT
About this fix:
Originally reported to Mozilla by members of Google Project Zero and Coinbase Security, the bug lets hackers use manipulated javascript code to trick users into visiting websites that deploy malicious code onto their PCs. This is a serious vulnerability, and the Mozilla Security board is urging all users to install the updates immediately—It’s even bad enough that the US Cybersecurity and Infrastructure Security Agency has even gotten involved in spreading the word about the patch.


EDIT 2
 
Last edited:

Psychotext

Member
Oct 30, 2017
4,608
Not sure what's going on since this last update, but my tabs are crashing continuously.


...and when they're not crashing, they're reloading when I click them.
 
Last edited:

Sejanoz

Member
Nov 10, 2017
793
Anyone else using the ResetEra VideoGif extension? I noticed it's replacing gifs into plain jpgs, instead of gifvs/webms.
Is it a bug? Something on my end? Do you know who made the extension?

EDIT: looks like it only happens with Imgur gifs
 
Last edited:

yagal

Member
Oct 25, 2017
1,576
Hi everyone,
New user here coming from Google Chrome, is there a way to change how Bookmarks are displayed? I'm not a fan of the sidebar. I want something that looked like what I had on Chrome
 
Oct 25, 2017
4,150
I'm not sure if I'm on the right place, but this forum won't let me view the twitter media on some certain thread. Whenever I embed the Twitter media, the dialog popped up and said "Loading tweet", then disappears in a few seconds and all I seen is a blank but the embed media is still there. I'm on Firefox 69.0.1 and my browser engine is DuckDuckGo. Same happened on my mobile as well.
 

Hella

Member
Oct 27, 2017
15,052
I'm not sure I'm on the right place, but this forum won't let me view the twitter media on some certain thread. Whenever I embed the Twitter media, the dialog just said "Loading tweet", and then disappeared in a few seconds. I'm on Firefox 69.0.1 and my browser engine is DuckDuckGo. Same happened on the mobile as well.
Not certain on your issue, but if you have tracker blocking enabled on Firefox, it can block tweets. Clicking the shield icon/site information (near the address bar) and turning off blocking for this site will let tweets and some other embeds show up normally.
 

Static_Void

Member
Oct 30, 2018
3,410
north of the Dreamlands
I'm not sure if I'm on the right place, but this forum won't let me view the twitter media on some certain thread. Whenever I embed the Twitter media, the dialog popped up and said "Loading tweet", then disappears in a few seconds and all I seen is a blank but the embed media is still there. I'm on Firefox 69.0.1 and my browser engine is DuckDuckGo. Same happened on my mobile as well.
Do you have any kind of adblocker or content blocker installed? Twitter seems to have changed the underlying functionality of their different widgets lately, and lots of blockers haven’t been updated properly yet. As Hella mentions, it might also affect the baked-in tracking blocking functionality of Firefox.
 
Oct 25, 2017
4,150
It’s probably why. One of your filters is blocking Twitter for the time being. Try updating them, and if it doesn’t work just disable the one responsible for the problem until the filter’s provider figures out a workaround to the recent Twitter changes.
The current is 1.22.2 and it still affected that. The options has load of complex list and I have no idea where I find to disable it.
 
Last edited:

Static_Void

Member
Oct 30, 2018
3,410
north of the Dreamlands
I'm current on recent is 1.22.2 and it still affected that. The options has load of complex list and I have no idea where I find to disable it.
Go into Ublock Origin preferences (also called the dashboard), and go into the "filter lists" tab.

Things to try:

- If there's a big yellow "update now" button near the top, press that. It will update all your filters. Now try again. Is the Twitter widget loading correctly? If yes, success! If not, then:

- It's probably one of your filters that is responsible for the problem. My guess is something with "Social" or "Social Media" in the name. Find it (or them) and just untick the box left of the filter name. Then press the "Apply Changes" yellow button. Once done, try to load a page with a Twitter widget. If it solves the issue, wait a few weeks before enabling the filters again for the filter provider to push the right updates.
 
Oct 25, 2017
4,150
I've updated all of them. (I have 9 installed) and none of them found any related to "social" or "social media". I probably not have it installed in the plugin.

And iirc, I don't think Twitter.com support widgets anymore. It was disconnected from June 2016.
 
Oct 25, 2017
4,150
I have something similar to this issue

The error URL from his uBlock Origin filter is the same issue I'm having. But the problem is I can't seem to find a way to make it works cuz the whitelist thing is too complex for my standard.

And another this, but this one is still unsolved, so it's probably that is.
 
Oct 25, 2017
4,150
I give up. I just tried unchecked all filters and everything, and still no luck.

The last thing I checked it with "logger' from uBlock, and all I found was this


There were more like URL but it was randomly gibberish just like the above, and it doesn't means anything as when I disabled this already.

And this is my filter:



I'm tired, just tried, man....
 

Hella

Member
Oct 27, 2017
15,052
Futabaisthebest<3 I'd recommend running Firefox in safe mode (Help > Restart with all add-ons disabled). That will tell you whether it's an add-on or Firefox itself.

However, I don't use uBlock so I'm no help with that, unfortunately.
 

voodoo

Member
Oct 26, 2017
269
I'm not sure if I'm on the right place, but this forum won't let me view the twitter media on some certain thread. Whenever I embed the Twitter media, the dialog popped up and said "Loading tweet", then disappears in a few seconds and all I seen is a blank but the embed media is still there. I'm on Firefox 69.0.1 and my browser engine is DuckDuckGo. Same happened on my mobile as well.
If you have the duckduckgo extension, check show embedded tweets is enabled:

 
Oct 25, 2017
4,150
Really depends which one you are using. The native DuckDuckGo Privacy Browser app didn't even expose an option to allow it from what I could see. Had no such problems using Firefox Preview app.
I'm using a DDGo app, though. Maybe I can try switch back to Safari since I've already installed DDGo search engine in it.
 
Last edited:

voodoo

Member
Oct 26, 2017
269
I'm using a DDGo app, though. Maybe I can try switch back to Safari since I've already installed DDGo search engine in it.
Yeah, try with a different browser app. Changing the default search engine in your browser of choice to use DDG shouldn't mess with tweets embedded in pages you view. It seems that the DDG app seems to have this behaviour as a default you can't (yet) override.
 

Static_Void

Member
Oct 30, 2018
3,410
north of the Dreamlands

Static_Void

Member
Oct 30, 2018
3,410
north of the Dreamlands
I did some testing with Firefox 70, and the improvements for the macOS version are incredible. It's really impressive.