• The GiftBot 2.0 Launch Giveaway Extravaganza has come to a close with an astounding 8073 games given away to the community by 696 members, a huge success thanks to you! The gifting now continues with more official prizes in the new Gaming Giveaways |OT|. Leftover Steam codes are also being given away to the PC Gaming Era community.

Red Dead Redemption II PC performance thread

Premium Ghoul

Member
Oct 27, 2017
777
Australia
I maybe found something:

There is a <asyncComputeEnabled value="false" /> line in the settings.xml
I've changed the false into true and the Vulkan stuttering is gone. GPU utilization is down by ~4-5%. Performance is pretty similar though...
No idea what this setting really does, I thought async compute was always "on" in this game.
Maybe the stuttering is gone because of the lower GPU utilization? I don't know.

I haven't tried this for long, but maybe give it a try yourself.
I hopped into Saint Denis and walked around and within ten seconds my game had already started stuttering like mad. I quit out, changed that line in the xml file, loaded back into the same exact scene and my frame times were smooth!

Thanks so much for finding this! That stuttering was really getting on my nerves.
 

Nekrono

Member
May 17, 2018
363
Thats really odd.. as I can play this game with an almost steady 58-60fps which never stutters at all, with high and medium settings on my gtx 1060 and i5 8500

You got the latest nvidia driver ?
You running the game on vulkan ?
HDD or SSD ? is the hdd slow
Mind sharing your settings? I have a 1070 Ti and a i5 8400 and I'm getting around 45ish FPS with a mix of high/med settings.

I'm playing in 2560x1080 Ultrawide though.
 

Emko

Member
Oct 3, 2018
13
Slovakia
So these seems to be my final settings for:
  • i5 8600K @ 4.65 GHz
  • 16 GB DDR4 @ 2964 MHz
  • GTX 1080 @ 2076/6000 MHz
  • 2560x1080 (x1.25: 3200x1350)
  • 20.0 ms / 49.989 FPS locked through RTSS
NVIDIA GeForce GTX 1080, DX12
2560 x 1080, 60Hz, Windowed: No, Vsync: Yes, Triple: On

Textures: Ultra
Anisotropic: 16x
Lighting: Medium
Global Illumination: High
Shadows: High
Far Shadows: Medium
SSAO: Ultra
Reflection: Medium
Mirror: High
Water: Custom
Volumetrics: Custom
Particles: Medium
Tessellation: High
FXAA: Off, TAA: High, MSAA: 0

Near Volumetrics Quality: Medium
Far Volumetric Quality: Medium
Volumetric Lighting Quality: Medium
Unlocked Volumetric Raymarch Resolution: Off
Particle Lighting Quality: Medium
Soft Shadows: High
Grass Shadows: Low
Long Shadows: On
Full resolution SSAO: Off
Water Refraction Quality: High
Water Reflection Quality: High
Water Physics Quality: 25%
Resolution scale: 125%
TAA Sharpen Intensity: 100%
Motion Blur: Off
Reflection MSAA: Off
Geometry Level of Detail: 100%
Grass Level of Detail: 66%
Tree Quality: Ultra
Parallax Occlusion Mapping Quality: High
Decal Quality: High
Fur Quality: High

Generated with Forceflow's RDR2 settings parser (https://bit.ly/2oZlIuy)
 
Last edited:

Chaz

The Fallen
Oct 25, 2017
2,919
Scotland, UK
Good to see more places reporting on the issues people are having. The game is gorgeous when it works but when a chunk of players need to update their bios just to play the game: You've dropped the fucking ball big time.

Does somebody know why gsync (vrr) does not work with vulkan on this game?
Turn on vsync in the graphics options.
(don't ask why, I don't know and R* probably don't either!)
 

ThreepQuest64

Avenger
Oct 29, 2017
3,069
Germany
Performance hit between high and ultra Parallax Occlusion Mapping is around 12%. Ultra setting adds visibly more details and geometry on ground textures like additional grass and small shadows and little stones. Performance between low, medium and high is neglectable (1%) but visual quality increases a bit. I recommend "high" instead of "ultra" if you struggling reaching your target fps.

Ultra:


High:


Also Geometry Level of Detail is broken. Highest setting actually removes objects from distance (maybe for accuracy?). Looks worse while performance worse.

Highest setting:


lowest setting:


Second lowest setting:


The higher the setting the more detail is lost in the distance. Look at the grass and bushes in the far, on the left, next to the rail tracks.
 
Last edited:
Oct 27, 2017
915
USA
Bumped down resolution scaling to like 0.800 and on my 3440x1440 screen I honestly can't really tell the difference and it's boosted frames a little bit, at least on my 1080Ti.

Still need to do some more testing.
 

SunBroDave

Member
Oct 25, 2017
1,529
Also Geometry Level of Detail is broken. Highest setting actually removes objects from distance (maybe for accuracy?). Looks worse while performance worse.

Highest setting:


Second lowest setting:
Whoa, that's messed up. Are you sure you don't have those pics reversed? And if that's really the case, is it a sliding scale where each higher level of the Geometry LOD setting removes more and more objects in the distance? Or is it only the highest setting that is bugged, in which case the best visuals will be the second highest setting?
 

ThreepQuest64

Avenger
Oct 29, 2017
3,069
Germany
is it a sliding scale where each higher level of the Geometry LOD setting removes more and more objects in the distance?
There was a mix up in those pictures between the lowest and second lowest, but it is correct now. No, unfortunatley not. See the fps left. 56fps on highest, 59 on lowest with more details. Each higher setting reduces the quality.

Any higher setting than the lowest actually reduces depth even in distance. Look at the new picture I added, right in front of Arthur.
 

Forceflow

Member
Nov 5, 2019
16
Just FYI, these are the options that - I think - are in the system.xml file but do not correspond to any sliders in the in-game settings menu:
(comments // by me, obviously). Might be some interesting performance wins in there.
// A win on AMD cards?
<asyncComputeEnabled value="false" />
// Probably should leave this to true
<transferQueuesEnabled value="true" />
// Motion blur factor?
<motionBlurLimit value="16.000000" />
// Sub Surface reflection for water?
<waterReflectionSSR value="true" />
// Amount of texture atlasses/chunk supdated per frame?
<maxTexUpgradesPerFrame value="5" />
<directionalShadowsAlpha value="false" />
<worldHeightShadowQuality value="0.660000" />
<directionalScreenSpaceShadowQuality value="0.660000" />
<ambientMaskVolumesHighPrecision value="true" />
// I think this only disables the visual effects of damage - won't make you invincible :)
<damageModelsDisabled value="false" />
<ssaoType value="0" />
// SSDO = Screen Space Directional Occlusion (an alternative to SSAO?)
<ssdoSampleCount value="4" />
<ssdoUseDualRadii value="false" />
<ssdoResolution>kSettingLevel_Low</ssdoResolution>
<ssdoTAABlendEnabled value="true" />
// SSRO? Screen Space ... Rays? Occlusion? Your guess is as good as mine
<ssroSampleCount value="2" />
// Don't like little specks of light in your snow?
<snowGlints value="true" />
// Globillum probes update rate?
<probeRelightEveryFrame value="false" />
// Pedestrian and vehicle LoD? Does 0 mean that by default, it always uses the high q model?
<pedLodBias value="0.000000" />
<vehicleLodBias value="0.000000" />
// Anoter sub surface scattering setting?
<deepsurfaceQuality>kSettingLevel_Ultra</deepsurfaceQuality>
 

robocopswitch

Member
Oct 2, 2018
12
On my 4690 and 1060 I found a performance sweet spot of 50-60 fps using Nvcp's Sharpening and resolution scaling of 0.9 (at 1080p). Using BES to stop game freezes. The async setting in the xml just makes the freezes way more extreme (using dx12).

Only real issue I have now is flickering trees/shadows when the wind blows, but that seems to be fixed by putting lighting settings on medium. Dunno, pretty hit and miss.

Nvcp's low latency mode also seems to help.
 

cwistofu

Member
Nov 29, 2017
784
Thats really odd.. as I can play this game with an almost steady 58-60fps which never stutters at all, with high and medium settings on my gtx 1060 and i5 8500

You got the latest nvidia driver ?
You running the game on vulkan ?
HDD or SSD ? is the hdd slow
Yes.
Vulkan causes the game to crash every time I try to start the benchmark or story mode. (DX12 doesn't freeze during the benchmark btw.)
Fresh SSD.

I have no clue what the issue is so I'm just pretending I have other games I'd rather play right now.
 

Nekrono

Member
May 17, 2018
363
Thanks! I did try lowering the resolution to 0.85ish but it looks kinda rough, I gain around 5 FPS but rather not lose definition.

I compared your settings to mine and I'm definitely running higher. I'll try to match yours, should get me to a stable 50 FPS. I'm just trying to stay away from 45 or less because it really doesn't feel that good even on gsync, 50 is smooth though.
 

porkproduct

The Fallen
Oct 27, 2017
1,766
got up at like 4am to play a bit. Crashed during the first mission to Valentine after turning onto the main road by the Sheriff's office. Tried just on my horse and it kept crashing there too. Tried a 3rd time and it crashed again right as I got onto the main rd again.

Swapped to Vulkan and it played just fine for a few hours until work. Had to also set vsync in-game to limit to 60.
 

Vintage

Member
Oct 27, 2017
621
Europe
Anyone figured out the 2-5 second freezes? Happens both on Vulcan and DX12
CPU 98% cap fixed it, I think OP should be more clear that is't not for stutter only, but for long freezes also
 
Last edited:

ThreepQuest64

Avenger
Oct 29, 2017
3,069
Germany
Finally managed to achieve 45-60fps (very demanding scenes still go sub-50fps but it's okay with Freesync) at native 1440p with a GTX 1070 (OC, +190Mhz Core/Memory) Ryzen 3600 and STILL have an awesome looking game.






How it looks:

 

Pwnz

Member
Oct 28, 2017
7,081
Places
Saint Denis, which I'm surprised it allowed me in early Chapter 3, runs without a hitch for me.

Specs:
AMD 3900X
NVidia 1080 Ti
32 GB RAM
1 TB PCIe SSD

Settings are:
nVidia recommended to start
Textures Ultra
Water quality 1
Direct mouse input
Xbox overlay disabled
NVidia overlay disabled
TAA medium
FXAA off
Near Volumetric Resolution High
Reflection Quality High
Resolution scale 5/4
1080p
 

hobblygobbly

Member
Oct 25, 2017
2,457
Baden-Württemberg
the game has been running fine for me, no perf/crash issues other than the occasional 5-10 second freezes, I'd say maybe 5-6 of them in a span of an hour.

I see lots of people have that issue, but still haven't heard of any reason why it's happening.
 

Lashley

Member
Oct 25, 2017
30,784
I decided to make the RDR2 desktop shortcut redirect to the R* launcher, since it was just taking up space on my desktop otherwise. It's easy to forget amid all the "I can't play the game at all" or "I needed to flash my BIOS to be able to start the launcher" stuff, the shortcut the launcher puts on your desktop can't even be used to start the game.

At this point, I'm not even mad, just stunned.
Yeah, it's fucking idiotic.
 

Lashley

Member
Oct 25, 2017
30,784
I maybe found something:

There is a <asyncComputeEnabled value="false" /> line in the settings.xml
I've changed the false into true and the Vulkan stuttering is gone. GPU utilization is down by ~4-5%. Performance is pretty similar though...
No idea what this setting really does, I thought async compute was always "on" in this game.
Maybe the stuttering is gone because of the lower GPU utilization? I don't know.

I haven't tried this for long, but maybe give it a try yourself.

I'm going to try this, cheers
 

Edgar

Member
Oct 29, 2017
4,486
guys. Arent you worried when your gpu usage is 95%+? I always think its better to have some headroom so i lower some options and resolution n stuff. Or am i worried for nothing and its fine if the usage is 95% during gaming?
 

Forceflow

Member
Nov 5, 2019
16
Yeah, it's fucking idiotic.
Yeah, I wonder how they are going to fix this for the Steam version. Currently, the only way to succesfully launch RDR2 is via the RGL, which passes hidden commandline arguments to the actual executable (they are listed in launch as @commandline.txt, but that's either a hidden file, or just in-memory - it's nowhere on my disk). This stops me from using the game for in-home streaming, since launching it directly is not an option, and adding the RGL to Steam as a non-steam-game, and launching the game from there crashes. (because of the streaming? Because it detects RGL has Steam as a parent application? I don't know.)

Does anyone have the EGS version of the game? How does the launch work there? You click play in EGS, have to click play again in the RGL?

In other news, the RDR2 Settings Parser is all prettied up and now understands the screen scaling parameter correctly. Thanks for everyone who's using it, feels good to make something useful :)
 

Lashley

Member
Oct 25, 2017
30,784
I maybe found something:

There is a <asyncComputeEnabled value="false" /> line in the settings.xml
I've changed the false into true and the Vulkan stuttering is gone. GPU utilization is down by ~4-5%. Performance is pretty similar though...
No idea what this setting really does, I thought async compute was always "on" in this game.
Maybe the stuttering is gone because of the lower GPU utilization? I don't know.

I haven't tried this for long, but maybe give it a try yourself.

Didn't work for me :(

If anything, it made em worse
 

Triscuitable

Member
Oct 27, 2017
2,785
guys. Arent you worried when your gpu usage is 95%+? I always think its better to have some headroom so i lower some options and resolution n stuff. Or am i worried for nothing and its fine if the usage is 95% during gaming?
Not at all. GPU usage being at or neat 100% isn’t just normal, it’s by design. If you’re not hitting 100%, it means either the game isn’t utilizing your hardware to the fullest (Evil Within 2) or your GPU is bottlenecked by your CPU.
 
Nov 5, 2019
3

This happens to me everytime I want to enter story mode when using DX12. As you can see and hear my PC is completely frozen and I can do nothing but turn it off with the power button.

Everything is fine when I use a Vulkan but I can't change the resolution then and this is important to me because I have a monitor with a different resolution than my main screen
 

Edgar

Member
Oct 29, 2017
4,486
Not at all. GPU usage being at or neat 100% isn’t just normal, it’s by design. If you’re not hitting 100%, it means either the game isn’t utilizing your hardware to the fullest (Evil Within 2) or your GPU is bottlenecked by your CPU.
I guess my reasoning was for gpu heating up if its very high usage. I remember having that issue with 780ti.
 

Paul

Member
Oct 27, 2017
2,483
Reading this thread is such a doozy. At this point I have doubts they will even manage to sort it out in time for steam launch. Jesus F. Christ Rockstar.