Red Dead Redemption II PC performance thread

Dan Longman

Member
Oct 28, 2017
4,403
Regina, Saskatchewan
I can’t get 5.1 to show up in my options at all. Just headphones and stereo.
do you have your windows set to 5.1? After the last Nvidia update it reverted mine to 2.0 and when I was playing RDR2 I was like why is it only in stereo, after resetting my speaker setup in sound control panel surround was back.

There is no option just if you have your windows set up to 5.1 it will use all the channels automatically.

Though if you have it set to 5.1 it allows you to adjust speaker location.
 

Cyanity

Member
Oct 25, 2017
6,265
Sat down with the new patch for the first time today and it seems like the mane and tail on my horse look significantly "grainier" and less soft than I remember? Does anyone know what might be causing this?

edit - actually the game seems more aliased in general, even though I still have the same 16x AA and TAA set to medium enabled
 
Last edited:

Cyanity

Member
Oct 25, 2017
6,265
Welp, thanks to the new patch I cannot get the mouse cursor to go away like before. This fucking sucks.
 

maenckman

Member
Dec 3, 2018
126
I am not sure if it‘s the patch or the fact I was using the Hardware Unboxed settings but it was the first time I managed the benchmark to get constant 60 fps at 4K. I will probably still use the 5/6 resolution scale as the actual game is a bit more demanding at times.
Anybody who is still struggling to find the best settings should definitely try the HUB suggestion.
 

BraXzy

Member
Oct 25, 2017
1,190
Last night I was getting lots of really weird flickering with shadows / lights - possibly only from indoor lamps etc. It was really odd but I can barely find anything online with similar issues. I'm hoping it fixes itself...
 

Dan Longman

Member
Oct 28, 2017
4,403
Regina, Saskatchewan
I have found a spot I can get the game to crash every single time.

this issue is weird I can reproduce it but requires a very specific world environment in St Denis but only at night and foggy.
Certain areas in the city will crash my game and throw a "Display driver nvlddmkm stopped responding and has successfully recovered." in the event log.
There are certain areas that this will happen.

When it happens it the screen may fill up with black polygons with crazy geometry then crash, or it will just freeze. I captured a video of the crash coming out the hotel:

and here is the one at the saloon that is repeatable. if I turn down settings this doesn't happen.

this happens 100% of time with these settings (see below)

My GPU is overclocked and watercooled. If I remove the overclock and go to complete stock settings the crash will still happen.

I captured a crash here with GPU View:

running with these settings:
3840 x 2160, 60hz, Windowed: No, Vsync: Yes, Triple: On

Textures: Ultra
Anisotropic: 16x
Lighting: Ultra
Global Illumination: Ultra
Shadows: High
Far Shadows: Ultra
SSAO: High
Reflection: High
Mirror: Ultra
Water: Custom
Volumetrics: Custom
Particles: Ultra
Tessellation: Ultra
FXAA: Off, TAA: Medium, MSAA: 0

Near Volumetrics Quality: Ultra
Far Volumetric Quality: Ultra
Volumetric Lighting Quality: Ultra
Unlocked Volumetric Raymarch Resolution: Off
Particle Lighting Quality: High
Soft Shadows: High
Grass Shadows: Medium
Long Shadows: On
Full resolution SSAO: Off
Water Refraction Quality: Medium
Water Reflection Quality: Medium
Water Physics Quality: 50%
Resolution scale: Mode4o5 80%
TAA Sharpen Intensity: 100%
Motion Blur: On
Reflection MSAA: Off
Geometry Level of Detail: 100%
Grass Level of Detail: 83%
Tree Quality: High
Parallax Occlusion Mapping Quality: High
Decal Quality: High
Fur Quality: High

HDR on but happens with HDR off as show in my videos.

happens both with Vulkan and DX12

In St Denis at night go to the ST Denis Saloon and spin camera around. Always happens here.

Happens elsewhere in ST Denis, but ONLY in St Denis at night.

It is one of the settings if I turn them down the issue doesn't happen. in the 30 hours I have played this crash only happens in St Denis at night.


Happens with RTSS completely disabled as well as enabled.

I have no other crashes in any other games


-
Submitted this to both Nvidia and Rockstar fwiw
Regarding this crash. Still happening on newest drivers and game patch.

But I've been working with Nvidia on it and they've been really great. Rockstar on the other hand not at all. But good news is Nvidia has proven it's a legit game bug. Response I have just gotten back from them:
Good news and bad news. We were able to reproduce the crash as your described. Unfortunately we were able to reproduce the crash on a competitor card as well so this looks like a game bug. Not a driver bug. Our developer relations team is going to reach out to Rockstar to share our findings. Thank you for submitting this bug. If you run into any other issues that look like driver bugs, please feel free to let us know.

Regards,
Manuel
 

Silverstoned

Member
Dec 28, 2017
155
North California
So it looks like the patch has really improved things for me.

i5 6600k
Strix GTX 1060 6gb

I was having pretty good performance but Id get frequent unpredictable freezes making the game unplayable for more than a few minutes at a time.

This patch has markedly improved performance and got rid of all the CPU spikes and crashes. Last night I played for a solid 3 hours including some multi player too.

Really pleased. While this should have been fixed before release I'm pleasantly surprised with this turnaround.
and now that I have got home today, the game freezes during launch.

as i tried to launch the launcher gave me a conflict of save files message (I DLed the latest from the cloud)

then the freeze.....

its when you have a loading bar at the bottom of the screen.

Ive verified integrity of files. can someone help? everything was finally awesome and now its gone..... just as quickly...... :(
 
Oct 27, 2017
2,717
Portland, OR
and now that I have got home today, the game freezes during launch.

as i tried to launch the launcher gave me a conflict of save files message (I DLed the latest from the cloud)

then the freeze.....

its when you have a loading bar at the bottom of the screen.

Ive verified integrity of files. can someone help? everything was finally awesome and now its gone..... just as quickly...... :(
I don't know if it's the issue, but I have noticed a couple times on exit that the game very briefly displays an "ALERT" screen and then immediately exits so I can't see what it says. Every time it happens, the next time I start it I get the error about save file discrepancy between local and the cloud. I've always selected local and it works for me after that. So I don't know if perhaps your cloud save was corrupted and now it's causing a loading issue? I don't know of a fix for that though.
 

Nintendo

Member
Oct 27, 2017
10,000
Never had a problem since launch until Windows decided to update and now the game won't launch. Fuck me. I guess I'll stick with Jedi Fallen Order for now.

EDIT: Verified the files and now it work just fine.
 
Last edited:

sredgrin

Member
Oct 27, 2017
5,689
Might be a driver issue, then. I'm running with a Sound Blaster Audigy FX.
Are you on a Ryzen CPU? I've been having 5.1 issues in a ton of games with Sound Blaster Z, and it looks like it's not all that rare, especially with MSI and Gigabyte motherboards.

The "muffled" voices you're experiencing is likely it getting routed into the wrong channel. Had it a lot in Gears 5, to the point where I'm running games in stereo until I find a fix.
 

Cross-Section

Member
Oct 27, 2017
3,769
Are you on a Ryzen CPU? I've been having 5.1 issues in a ton of games with Sound Blaster Z, and it looks like it's not all that rare, especially with MSI and Gigabyte motherboards.

The "muffled" voices you're experiencing is likely it getting routed into the wrong channel. Had it a lot in Gears 5, to the point where I'm running games in stereo until I find a fix.
Yeeup, 2700x here, on a MSI B450 Gaming Pro Carbon AC mobo.

Thing is, this is the first recent release I've had these issues with. Control, Outer Worlds, and Jedi Fallen Order all sound fine.
 

sredgrin

Member
Oct 27, 2017
5,689
Yeeup, 2700x here, on a MSI B450 Gaming Pro Carbon AC mobo.

Thing is, this is the first recent release I've had these issues with. Control, Outer Worlds, and Jedi Fallen Order all sound fine.


Check out this thread, has a few trouble shooting tips. It looks like BIOS updates fixed it for a few Sound Blaster types (not the Z like I have though).

The 16 bit thing seems to help delay it, in my experience.
 

Samaritan

Member
Oct 25, 2017
2,941
Idaho
I think I'm just going to uninstall this for now and wait for the game to mature a bit, and for that hilarious/baffling framerate weight loss bug to get fixed. That honestly killed any momentum I had wanting to keep playing this.
 
Last edited:

dex3108

Member
Oct 26, 2017
9,350
Whatever you do push resolution above 1080p, even if that means slightly above 1080p. Game looks much much better above 1080p. If you can do push resolution scale to x1.25
 

furfoot

Member
Dec 12, 2017
106
Gsync freaks out on me on first load with vulkan. Each time I start the game I have to toggle refresh rate one notch up and then one notch down before VRR works properly.
 

scrambledeggs

Member
Apr 25, 2018
253
Anyone stop playing the game at 60+ fps after it was discovered that certain features are tied to the framerate? I’m thinking of just capping it at 30fps. It’s gonna hurt, but fuck it. I’ll get used to it lol. :(
 

Letters

Avenger
Oct 27, 2017
1,308
Anyone stop playing the game at 60+ fps after it was discovered that certain features are tied to the framerate? I’m thinking of just capping it at 30fps. It’s gonna hurt, but fuck it. I’ll get used to it lol. :(
Nah I’m good. I don’t mind actually having a use for all the food I’m always carrying around.
 

Dan Longman

Member
Oct 28, 2017
4,403
Regina, Saskatchewan
I got to the epilogue today and played at 60 the whole time, the cores do drain a bit faster then they did on the ps4 but it's still super generous and I always had way more provisions then I needed. Honestly it's better, the cores were 100% ignoble on ps4
 

PHOENIXZERO

Member
Oct 29, 2017
6,004
Still only in chapter 2 but been running fine capped at 30FPS with mostly high and ultra settings and resolution scaled up at 1080x1.5 on my OC'd 2500k and 1070.
 

Cyanity

Member
Oct 25, 2017
6,265
Regarding this crash. Still happening on newest drivers and game patch.

But I've been working with Nvidia on it and they've been really great. Rockstar on the other hand not at all. But good news is Nvidia has proven it's a legit game bug. Response I have just gotten back from them:
You're doing the lord's work here. Thank you
 
Nov 17, 2017
1,753
Repurchased the game because I’m a sucker. Online works great for me, no crashes. I haven’t tried the story since my fiasco. Does online run better than the campaign, I’m too lazy to test, but I had bad stutters in towns which seem to be gone online.
 

Nekrono

Member
May 17, 2018
387
Has anyone noticed this after the patch? I'm almost sure this wasn't happening before yesterday's patch and I'm running the same settings as before.



Notice how the wheel and horse tracks are fading in and out. I've maxed out tessellation, decals, parallax mapping but I can't seem to extend the range in which it fades.

Can someone confirm if this was the same behavior before the patch?
Fix found here.
Go into system.xml in the My Documents RDR2 settings folder and change the <DeepSurfaceQuality> string from Low to Ultra.

Seems latest patch broke a few settings that are not in the menu.
For anyone wondering when the latest patch reset the settings to low it also reset a couple of settings that aren't in the menu. This change isn't needed on new inis. The other setting that got disabled was snowGlints.
 

laxu

Member
Nov 26, 2017
1,278
Man HDR is really broken in this version. Can't get it working right in either DX12 or Vulkan. Always looks extremely desaturated and bright. It doesn't look that bad on consoles.
 

J75

Member
Sep 29, 2018
1,569
Anyone stop playing the game at 60+ fps after it was discovered that certain features are tied to the framerate? I’m thinking of just capping it at 30fps. It’s gonna hurt, but fuck it. I’ll get used to it lol. :(
Thinking about doing this, if i cap it at 30, i could run it at native 4K. Hmmm
 

SirMossyBloke

Member
Oct 26, 2017
3,686
Theres supposed to be a launcher patch coming which fixes HDR on Vulcan. I can get it to work on DX12 no problem, but I drop below 60 vs Vulkan. Anyone know when the patch is out? Tried HDR again on Vulkan and its still broken.
 

Premium Ghoul

Member
Oct 27, 2017
899
Australia
Anyone stop playing the game at 60+ fps after it was discovered that certain features are tied to the framerate? I’m thinking of just capping it at 30fps. It’s gonna hurt, but fuck it. I’ll get used to it lol. :(
I tried 30fps for a couple of hours and it was fine. But then I went back to an uncapped frame rate with slightly lower settings and the difference was night and day. For me frame rate is king above all else, even if it's a little buggy.
 

Felix Lighter

Member
Oct 25, 2017
124
I'm having an issue that actually popped up right before the previous patch released and continues to be an issue. Sometimes when I load my game the second the loading is finished I get a crash with a dialog message telling me the game needs to be rebooted. It will continue to do that everytime I load the game. Oddly enough the thing that appears to work around the issue is to run the benchmark to completion and then the game will load without issue. Has anyone else experienced this issue? It's now happened 3 times to me.