ResetEra Tech Thread - 5/24/19 Site Update (Report Bugs Here)

Shoshi

Member
Jan 9, 2018
898
On iOS 12.3.1 on iphone SE and since last week often when I open a thread, the ”Reader View” mode in the upper left corner activates by itself.
 

Lnds500

Member
Oct 27, 2017
998
So it's not really a bug but the favicon on macOS on Safari is white and black. Is there a way to change it back to purple and white?
 

hyouko

Member
Oct 27, 2017
710
I have been having trouble accessing the site on my home internet connection (FiOS). Not an expert, but I suspect some sort of DNS issue; when I try to ping the site I get timeouts. I tried switching to a few different DNS servers (8.8.8.8, 1.1.1.1, and the default Verizon one); on the default Verizon DNS I was able to get the site to load briefly and saw that the IP resolved to something different when pinging. I've disabled any adblocking and the "traffic protection" functions on my router.

The site works fine when loaded via cell network on my phone (which is how I am posting). Will check what it looks like on the office connection when I get to work.
 

Otakukidd

Member
Oct 25, 2017
342
I have been having trouble accessing the site on my home internet connection (FiOS). Not an expert, but I suspect some sort of DNS issue; when I try to ping the site I get timeouts. I tried switching to a few different DNS servers (8.8.8.8, 1.1.1.1, and the default Verizon one); on the default Verizon DNS I was able to get the site to load briefly and saw that the IP resolved to something different when pinging. I've disabled any adblocking and the "traffic protection" functions on my router.

The site works fine when loaded via cell network on my phone (which is how I am posting). Will check what it looks like on the office connection when I get to work.
I want to second this. I access the site through VPN at work though pia VPN or free VPN. If the VPN is on the site doesn't work but all others do and if the VPN is off then I get a too many redirects error. Will check at home later if pia works on my home PC.
 

Mint

Member
Oct 26, 2017
947
Canada
Maybe it’s just me but every time I try to hit the light / dark theme shortcut in the menu on my iPhone X, the safari toolbar opens up and blocks the button and I can’t seem to scroll down to get to it.
 

Twig

Member
Oct 25, 2017
4,842
Why does the page jump around in mobile mode three times when I first open a thread before it finally settles, causing me to click on things I absolutely did not want to click on?

Why does opening the search bar on mobile to find the post I was reading, after the above happens so much I lost the page I was on, pop up the keyboard and then immediately kill it, ten times in a row, before I give up?

Why does writing a post on mobile completely and absolutely destroy performance, making it near impossible to write anything but a single sentence before I throw my phone at a wall?
 

lobdale

Member
Oct 25, 2017
847
Why does the page jump around in mobile mode three times when I first open a thread before it finally settles, causing me to click on things I absolutely did not want to click on?
Seconding this, it is 100 percent infuriating and has been like this for months, the subforum selection page is extra irritating
 

Mipmap

Member
Nov 1, 2017
296
Is this the correct thread for suggesting features?

One of my frustrations with embedded media (mostly youtube) is when you get "video unavailable" and the only way to actually watch the video is to right click and copy the URL and paste in another tab. One way around this would be to automatically add a small url or hyperlink below the video. Even a small icon next to the video that you could click to open in a new tab could possibly work.

Something like this for example:

Video: MGMT - When You Die <-- add this part automatically

Either this or an easier way to click through to the video after getting the "video unavailable" prompt without having to right click.
 

Korigama

Member
Oct 25, 2017
7,996
"The active user has changed. Reload the page for the latest version."

I had never seen this error before, but have now been getting it since yesterday.
 

SwordStruck

Member
Oct 27, 2017
1,090
The jumpiness on mobile is just ridiculous. As mentioned, it's literally one CSS declaration to fix that.
 

Reki

Member
Oct 25, 2017
825
You can obviously disagree with the final decision, but the ad container height was addressed already;

When you load a page the ad banner takes several seconds to load in, and when it does it pushes the entire page down. This has repeatedly caused me to tap a different thread title and other things due to it loading in right when I tap. It'd be nice if the size of the banner is coded in to the layout, so when the ad loads it doesn't move the page.
We've investigated solutions to this and unfortunately there isn't a perfect one. The best we could do is create a fixed container for it, and we did in fact test that solution on the old design, but the result was that it cut off the "Report Ad" link underneath the ads and members were no longer able to report bad ads directly. That obviously generated a lot of complaints as well, and in the end we decided to err on the side of allowing reports.
 

SwordStruck

Member
Oct 27, 2017
1,090
So they didn't fix it because they didn't want to simply put the 'report ad' link in another container? Not trying to be a backseat web developer here but that's fucking easy.
 

Reki

Member
Oct 25, 2017
825
I obviously can't speak for the admins but best guess is that it isn't that easy. Otherwise they would have solved it already considering the volume of complaints this problem has received on multiple occasions.
 

Mr. X

Member
Oct 25, 2017
5,256
The google authentication hasn't given a working code in months for me. Been using email authentication.
 

Twig

Member
Oct 25, 2017
4,842
To be frank, I don't care what the excuse is. The page jumping around on mobile is unacceptable. I'm not usually one to take a hardline stance on things like this, but it's majorly fucked.
 

Tathanen

Member
Oct 25, 2017
1,287
To be frank, I don't care what the excuse is. The page jumping around on mobile is unacceptable. I'm not usually one to take a hardline stance on things like this, but it's majorly fucked.
Basically this.

If the report text is cut off, make the fixed height... higher. If it's only certain ads that are taller than the "standard" height, absolute-position the ad content within the container with bottom: 0, so the top gets cut off, not the bottom with the text. If the shit loads dynamically in a weird way that prevents these from working, just don't hide overflow on the container, better the report text bleed out than be hidden. If that doesn't work, set the container to flex and change the flex-direction to column-reverse so the report link appears first.

There are so many options here. This is not an insurmountable technology problem, and the user experience as-is is borderline catastrophic.
 
OP
OP
Cerium

Cerium

General Manager
Administrator
Oct 23, 2017
1,164
The cutoff was not the only technical problem we ran into while trying to implement a container -- the different layouts on mobile vs desktop also caused some unexpected problems. We consulted with three different people on this issue, none of whom were able to achieve a satisfactory solution.

We WILL consult with a larger contractor to see what they can come up with. We understand the complaint and will pursue the issue until we find a solution that works. It's really just not as simple as it might seem.
 

Shyotl

Member
Oct 25, 2017
355
To be frank, I don't care what the excuse is. The page jumping around on mobile is unacceptable. I'm not usually one to take a hardline stance on things like this, but it's majorly fucked.
Lately i've been getting ads that are a good 3-4x taller than normal, which makes this even worse. Add on top of that ads that update to new dimensions constantly and it's just a nightmare, even on pc. The pages are constantly and seemingly randomly re-flowing and I frequently lose track of where I am in threads or click the wrong thing 3-4 times as I quite literally fight against loading ads. Makes this site so frustrating to use.
 

Teppic

Member
Oct 25, 2017
340
The layout is a bit broken on mobile in the main gaming page with extra large fonts. Probably because of the Indivisible thread.

Edit: and now it's the River City Girls thread that is breaking the design. I guess if a thread has a really long word in it the page gets broken.
 
Last edited:

Dineren

The Fallen
Oct 25, 2017
1,527
"The active user has changed. Reload the page for the latest version."

I had never seen this error before, but have now been getting it since yesterday.
I'm getting the same thing. Not sure when it started, maybe late last week and as far as I know it only happens at work when I'm connected to a VPN.
 

Krejlooc

Indie Game Dev
Verified
Oct 27, 2017
18,556
Why can people who you have ignored PM you? This is something I've noticed for a while but haven't tried reaching out to ask about, but it's currently possible for people on your ignore list to PM you. Is that by design?
 

Fuzzy

The Fallen
Oct 25, 2017
6,775
Toronto, Canada
Why can people who you have ignored PM you? This is something I've noticed for a while but haven't tried reaching out to ask about, but it's currently possible for people on your ignore list to PM you. Is that by design?
That's horrible. I don't currently have anyone on ignore but I wouldn't want to hear from them at all if I did.
 
OP
OP
Cerium

Cerium

General Manager
Administrator
Oct 23, 2017
1,164
Why can people who you have ignored PM you? This is something I've noticed for a while but haven't tried reaching out to ask about, but it's currently possible for people on your ignore list to PM you. Is that by design?
You definitely shouldn't be seeing those. Please report the PM so that we can investigate what's going on there.
 
Added container for top mobile banner ad
OP
OP
Cerium

Cerium

General Manager
Administrator
Oct 23, 2017
1,164
Official Staff Communication
By popular demand, we have implemented a fixed-height container for the top banner ad on mobile. This should prevent content from shifting up and down, while preserving access to the "Report Ad" link.

Please let us know if you observe any problems or unexpected consequences related to this update.
 
Oct 25, 2017
5,163
The search function has been fucking with me for months and I finally caught at least one example in action.
Why doesn't search find the thread I'm looking for? Does it only go back a few months?







And I'll confirm ahead of time that MrConbon210 is not an ignored user and this is not an ignored thread.
 

CloseTalker

Member
Oct 25, 2017
9,382
I have a feature idea/request, if it's at all feasible. Would it be possible to implement a "Turn off Notifications for this post/thread" option? Sometimes a user will make a post with a question or comment, and then someone will quote that post and answer the question, which is great. Trouble is, other users tend to not read full threads, which leads to the same questions or comments being replied to repeatedly with the same information, and bombarding you with notifications you'd rather not receive.

I don't know if this has been brought up before, or if it's at all possible, but it's a QOL feature that would honestly be a game changer for me.
 
Nov 5, 2017
808

dallow_bg

Member
Oct 28, 2017
5,105
texas
Is there a certain amount of time that the memory of last unread "expires"?
When older threads I"m subscribed to get new posts it takes me to the first page. Just thought I'd ask if perhaps maybe that could be changed.

Seems like a month, maybe 2.
 

Number45

Member
Oct 25, 2017
2,791
Is there a certain amount of time that the memory of last unread "expires"?
When older threads I"m subscribed to get new posts it takes me to the first page. Just thought I'd ask if perhaps maybe that could be changed.

Seems like a month, maybe 2.
Yeah there definitely is, though I don't know what the limit is. You can still click jump to new though and it'll take you to the proper post.
 

TsuWave

Member
Oct 27, 2017
1,792
will the site ever support non-paid for emails addresses? just asking because I'm gonna cancel my sub with my current email provider and i wanted to change my Era email to my gmail address at least until I sub to a different paid-for email service (didn't want to risk my account being in limbo while i make the transition).

I had to log on gaf to see if I could get my old university email to try and use that for Era in the meantime since gmail is not supported but no luck.

I am just asking for future reference btw
 

Eylos

Member
Oct 25, 2017
7,164
Idk If its my cellphone, but It only happens here, recently the site hangs/stops when i refresh the forum/enter a thread and then scroll the page, so i have to wait some seconds until it becomes responsive again. This happens in another browser too so idk If its something weird with my cellphone and here.
 
OP
OP
Cerium

Cerium

General Manager
Administrator
Oct 23, 2017
1,164
will the site ever support non-paid for emails addresses? just asking because I'm gonna cancel my sub with my current email provider and i wanted to change my Era email to my gmail address at least until I sub to a different paid-for email service (didn't want to risk my account being in limbo while i make the transition).
No need to worry; your account should remain valid no matter what happens to your old email. The only thing you'd lose is the ability to reset your password via email if you lock yourself out of your account. If you absolutely must change your email in the interim, drop me a PM and I'll see what I can do.

The search function has been fucking with me for months and I finally caught at least one example in action.
Why doesn't search find the thread I'm looking for? Does it only go back a few months?
Looks like a problem with the search index. The fix is straightforward, but it's also tedious and will result in search being disabled for most of a day. We'll try to get to it this weekend.