Welcome to ResetEra 2.0! Report bugs here (Check "Staff Posts" at the top of the thread for updates)

Oct 27, 2017
1,231
I made my peace with never being happy with the mobile site because without options (which would be too difficult) I know it'll never be more than average for me.
Im pretty happy with the mobile site now. If they put in my change then I would be pretty much perfect. Im used to how things work now, but the bottom bar was so useful in the original site, it needs to come back.
 
Oct 27, 2017
3,455
No, really, I know I already said this but resetera is almost unusable for me on mobile, it's very unresponsive, laggy, and the window for posts is WAY TOO SMALL...


It's also jumping around like crazy when I try to do something like adding pictures, etc.


Also even though it's so small often just scrolling through posts activates the keyboard, which often results in me typing "8" or whatever, it's also really tedious to go back to the last post I read when that happens...


It also loves to jump to the bottom of the page for no reason.

As a result a simple post that would take less than a minute often takes 8-10 minutes...

I don't know how widespread this is or if there's a fix... I hope there's a fix though.

PS: I know, I gotta charge...
 
Oct 27, 2017
2,492
The forum is changing URLs that link directly to a post, to link to the post and the page it's on.
The problem is that page numbers are different depending on your view settings.
The first URL links directly to the post no matter your view settings, the updated links only work if your view settings match the link.
 
Oct 25, 2017
1,234
There's something going on lately where my CPU usage is going through the roof using Chrome just sitting here reading a thread.

Using Chrome 73.0.3673.0 on macOS Mojave.
There is something going on with Chrome and this site in general then because i'm on Chrome 71.0.3578.98 for Windows and CPU usage is absolutely absurd since yesterday. Using Chrome's own task manager I can see the CPU spiking from like 5% to 30-50% or higher every time a new add cycles and it goes up to about 20% usage just from scrolling through pages, both the thread listings and threads themselves (with no media embedded either).
 
OP
OP
Cerium

Cerium

General Manager
Administrator
Oct 23, 2017
752
There is something going on with Chrome and this site in general then because i'm on Chrome 71.0.3578.98 for Windows and CPU usage is absolutely absurd since yesterday. Using Chrome's own task manager I can see the CPU spiking from like 5% to 30-50% or higher every time a new add cycles and it goes up to about 20% usage just from scrolling through pages, both the thread listings and threads themselves (with no media embedded either).
Sounds like a bad ad might be coming through. I've sent an urgent email to the relevant people who can look into this.
 
Oct 28, 2017
1,012
What's with the image viewing setup on mobile? Click and image and you get two views, zoomed in completely or zoomed out. What happened to pinch controls for zoom?
 
Oct 25, 2017
2,694
Finland
Are watched threads somewhat broken again for anyone else? I just added a new thread on gaming to my list but it isn't showing up at all.

Actually never mind, didn't realize I had the thread creator on ignore and that's why it didn't show in the watch list. Carry on.
 
Last edited:
Dec 3, 2018
303
After i paste a link to the box to insert a gif or a link or a pic the box disappears

This is on Android and Firefox

*edit*

So it works, but took three tries, so it disappeared two times and stuck around on third
 
Last edited:
Oct 26, 2017
6,142
I'm recently really often running into the issue that embedded tweets sometimes just dont load, just showing the blue twitter symbol. Have this happening on desktop Chrome and on mobile with Firefox both.
 
Oct 25, 2017
2,528
I'm recently really often running into the issue that embedded tweets sometimes just dont load, just showing the blue twitter symbol. Have this happening on desktop Chrome and on mobile with Firefox both.
I'm having trouble loading Twitter period. Could very well be an issue on that end.
 
Oct 27, 2017
333
Seems that a fix was attempted for enabling the ability to hide certain forums from the front page through the toggle arrow, but for some reason it is hiding both the Official section by default when I never chose to hide them in the first place. It also doesn't seem to be complying for Discussion either. To test it out I hid the Discussion section and then undid that, yet from a refresh it was back to hid.

Some help for this would be appreciated. Also, any update on thread previews that I've requested before?
 

LQX

Member
Oct 25, 2017
923
Not sure if keyboard or mouse is going bad and might be causing this but I keep having to hit the"insert" key so not have to keep deleting what I'm typing. Anyone else experiencing this?
 
Oct 27, 2017
3,024
Costa Rica
I have a feature request: I want to have push notifications!

Having an option to receive forum notifications as web push notifications would be so useful. I've seen some forums using Xenforo 2.0 with that feature and I love it.
 
Oct 25, 2017
2,528
How many media embeds are supported in one post? I'm working on a thread with quite a few tweets and I'd like to know the limit before submitting it. Thanks.
It used to be two, but I'm embedding random tweets in this reply to test that.

EDIT: OK, looks like the limit is definitely raised, because I was able to embed three. Didn't try for more though.
 
Oct 25, 2017
4,420
Toronto
How many media embeds are supported in one post? I'm working on a thread with quite a few tweets and I'd like to know the limit before submitting it. Thanks.
I think it got raised to 4 but OPs should probably just screencap tweets then link to them underneath the pic in case the tweet is deleted anyway.
 

Anustart

9 Million Scovilles
Member
Nov 12, 2017
1,389
Thanks for the report: This should now be fixed!
Still happening for me, as well as random scrolling in Mobile chrome where the site randomly decides I should be looking.

Edit: on the search thing, it happens randomly. In this thread the bug happens all the time but not when browsing a board instead of being in a thread.
 
Last edited:
Oct 25, 2017
3,011
Still getting some high CPU usage when I'm just sitting on thread pages with Chrome. No idea what's causing this.

edit: Just to clarify, this doesn't happen on any other pages on the site (like the home page or thread list pages), only when I'm in a thread.
 
OP
OP
Cerium

Cerium

General Manager
Administrator
Oct 23, 2017
752
How many media embeds are supported in one post? I'm working on a thread with quite a few tweets and I'd like to know the limit before submitting it. Thanks.
The limit should be 4 right now.

I have a feature request: I want to have push notifications!

Having an option to receive forum notifications as web push notifications would be so useful. I've seen some forums using Xenforo 2.0 with that feature and I love it.
We are in fact planning to add this, but we have more urgent priorities right now so it's not anything imminent. I would say six months to a year. But it'll happen eventually.
 
Am I imagining things, or are the "Hangouts" in the sidebar visible by default as of very recently?

Could they possibly be aligned to the right (text as well as icon) and not to the very left with no tab-space between the icon and the text? That looks visually confusing to me as it gives them the appearance of the important headline and not the less important sub-option.
 

Dojima

Banned
Member
Jan 25, 2019
1,097
Hello everyone. I have a problem whenever I Access the site from the laptop. The “Discussion” and “Official” sections are always closed whenever I return to the home page. No matter how many time I open, it closes again. On Safari
 
Oct 25, 2017
2,948
France
No, really, I know I already said this but resetera is almost unusable for me on mobile, it's very unresponsive, laggy, and the window for posts is WAY TOO SMALL...


It's also jumping around like crazy when I try to do something like adding pictures, etc.


Also even though it's so small often just scrolling through posts activates the keyboard, which often results in me typing "8" or whatever, it's also really tedious to go back to the last post I read when that happens...


It also loves to jump to the bottom of the page for no reason.

As a result a simple post that would take less than a minute often takes 8-10 minutes...

I don't know how widespread this is or if there's a fix... I hope there's a fix though.

PS: I know, I gotta charge...
Exactly the same issues for me. It was fine a few months (weeks?) ago, but now I've stopped browing the site on mobile.

PS: and yes, charge your phone! :p
 

Coreda

SVG Wizard
Member
Oct 26, 2017
884
The forum is changing URLs that link directly to a post, to link to the post and the page it's on.
The problem is that page numbers are different depending on your view settings.
*snip*
The first URL links directly to the post no matter your view settings, the updated links only work if your view settings match the link.
The permalinks in posts are as the first link for me. Do you mean when copying them or visiting the links? (Or was this changed and then reverted between my post and yours).
 

TI92

Alt account
Member
Oct 25, 2017
5,598
I'm a little confused on the Video Games/EtcetEra drop downs, the arrow points down when it's open and up when it's closed? Shouldnt the little arrows be the opposite since clicking it tells you what the button will do? Clicking when it's up makes it drop down which makes no sense. It would be like clicking a button that says "close" on it to open the garage door.
 
Oct 27, 2017
2,492
The permalinks in posts are as the first link for me. Do you mean when copying them or visiting the links? (Or was this changed and then reverted between my post and yours).
It was changed.

EDIT: Perhaps not. If you click a quote to go to that post, it still appends the page number to the address.
 
Last edited:

Coreda

SVG Wizard
Member
Oct 26, 2017
884
If you click a quote to go to that post, it still appends the page number to the address.
That's the expected behavior though as they're redirects. The post link in the top right of each post (eg: #3,924) is meant to be copied as-is, rather than clicked and then the URL copied from the addressbar. The same for copying 'go to quote' links. It's always been like this on the forum since permalinks were introduced.

Eg: the link for my post above is the following when right-clicked and copied (note the lack of page number):

Code:
https://www.resetera.com/threads/welcome-to-resetera-2-0-report-bugs-here-check-staff-posts-at-the-top-of-the-thread-for-updates.84593/post-17310367
And the 'go to quote' link (a neater permalink URL):

Code:
https://www.resetera.com/goto/post?id=17310367
Once either are clicked though they will expand to the full URL with page number and anchor link so the browser can scroll to the post on the page.
 

Coreda

SVG Wizard
Member
Oct 26, 2017
884
The page number is redundant (the links work fine without it) and means that you cannot share that link.
Just wondering, am I missing some UI that's not loading for me when the post link in the top-right is clicked or something? I recall the previous version of Xenforo we were on had them but I'm not seeing them in the new redesign. As currently from all I can see the permalink URLs meant to be shared/linked to are only the ones copied using the right-click context menu>'Copy link address', rather than the URL seen in the addressbar after the links have been clicked.

I'm also unclear on what you meant with 'the links work fine without it' given that once clicked (again, not the URL you want to be sharing/linking to) the board has to scroll to the post using anchor links on the page the post is on (whatever that may be based on user preference). Anyway, if I've missed some UI that's not loading let me know as otherwise the functionality is as I've always observed it.
 
Oct 27, 2017
2,492
Just wondering, am I missing some UI that's not loading for me when the post link in the top-right is clicked or something? I recall the previous version of Xenforo we were on had them but I'm not seeing them in the new redesign. As currently from all I can see the permalink URLs meant to be shared/linked to are only the ones copied using the right-click context menu>'Copy link address', rather than the URL seen in the addressbar after the links have been clicked.

I'm also unclear on what you meant with 'the links work fine without it' given that once clicked (again, not the URL you want to be sharing/linking to) the board has to scroll to the post using anchor links on the page the post is on (whatever that may be based on user preference). Anyway, if I've missed some UI that's not loading let me know as otherwise the functionality is as I've always observed it.
I'm used to hitting CTRL+L, CTRL+C to copy links if I have them opened in a tab. If I have scrolled past that post, I have to find it again and copy the link manually with the mouse.
If I edit that link and remove the part referencing the page, it still works correctly and takes me directly to the post, whether I'm signed in and viewing 100 posts-per-page or signed out and viewing the default 50 posts-per-page - so I'm not sure why it's being added at all?
It's not a big deal, just a minor annoyance that seems completely unnecessary.
 
Oct 27, 2017
1,292
Am I imagining things, or are the "Hangouts" in the sidebar visible by default as of very recently?

Could they possibly be aligned to the right (text as well as icon) and not to the very left with no tab-space between the icon and the text? That looks visually confusing to me as it gives them the appearance of the important headline and not the less important sub-option.
Yeah, if anything they should have more indentation than the main categories.
 
Oct 25, 2017
2,277
USA
Hello everyone. I have a problem whenever I Access the site from the laptop. The “Discussion” and “Official” sections are always closed whenever I return to the home page. No matter how many time I open, it closes again. On Safari
Yep, same and the browser is not remember my choices to keep them hidden
 

TI92

Alt account
Member
Oct 25, 2017
5,598
To reiterate on the drop-down UI being weird/bad here is an example of traditional drop down indicators:



Down arrow to signify that you can open this and what it will do when clicked. And then on the right when it's dropped down you signify to close it you click it again.

Not sure why resetera would buck the trend or if it's a bug but it's very confusing 😅
 

TI92

Alt account
Member
Oct 25, 2017
5,598
To reiterate on the drop-down UI being weird/bad here is an example of traditional drop down indicators:



Down arrow to signify that you can open this and what it will do when clicked. And then on the right when it's dropped down you signify to close it you click it again.

Not sure why resetera would buck the trend or if it's a bug but it's very confusing 😅
Nevermind looks like it was fixed already or was a bug on my computer
 
Oct 25, 2017
2,528
To reiterate on the drop-down UI being weird/bad here is an example of traditional drop down indicators:



Down arrow to signify that you can open this and what it will do when clicked. And then on the right when it's dropped down you signify to close it you click it again.

Not sure why resetera would buck the trend or if it's a bug but it's very confusing 😅
Collapsible menus and dropdown options are two different things. Era seems to echo Discord's behavior:

 
Oct 27, 2017
391
Am I imagining things, or are the "Hangouts" in the sidebar visible by default as of very recently?

Could they possibly be aligned to the right (text as well as icon) and not to the very left with no tab-space between the icon and the text? That looks visually confusing to me as it gives them the appearance of the important headline and not the less important sub-option.
Yeah, if anything they should have more indentation than the main categories.
I'm a little confused on the Video Games/EtcetEra drop downs, the arrow points down when it's open and up when it's closed? Shouldnt the little arrows be the opposite since clicking it tells you what the button will do? Clicking when it's up makes it drop down which makes no sense. It would be like clicking a button that says "close" on it to open the garage door.
I actually have found myself clicking on the Hangouts links by mistake because of this. Please do something about this. I made a mockup of what I feel like the sidebar should look like.

What it looks like:


What it should look like:


Also, they should be collapsed by default, and their state should be saved when navigating from page to page.
 
Oct 25, 2017
2,528
I actually have found myself clicking on the Hangouts links by mistake because of this. Please do something about this. I made a mockup of what I feel like the sidebar should look like.

What it looks like:


What it should look like:


Also, they should be collapsed by default, and their state should be saved when navigating from page to page.
Quick searching tells me collapsible menus with arrows pointing down is standard, and has been for a long time. What you're proposing is actually the opposite of established norms.

If anything, the only thing Era isn't compliant with that guideline on is the direction of the arrow when collapsed - it should be pointing to the side rather than up.
 
Oct 27, 2017
391
Quick searching tells me collapsible menus with arrows pointing down is standard, and has been for a long time. What you're proposing is actually the opposite of established norms.

If anything, the only thing Era isn't compliant with that guideline on is the direction of the arrow when collapsed - it should be pointing to the side rather than up.
So it is. In that case, leave the arrows as is (or change the collapsed one to an inward-pointing arrow). My main grievance is still the indentation and default/saved state of the collapsible areas -- I changed the arrows' directions mainly to address TI92's comment.
 

TI92

Alt account
Member
Oct 25, 2017
5,598
So it is. In that case, leave the arrows as is (or change the collapsed one to an inward-pointing arrow). My main grievance is still the indentation and default/saved state of the collapsible areas -- I changed the arrows' directions mainly to address TI92's comment.
Yeah side arrow and indentation I think would help me as well. It's definitely not intuitive as to what's going on.
 
Nov 17, 2017
333
Yeah if the 'hangouts' are going to be opened by default and not save their state when changing pages there's literally no reason for them to be collapsible/closable lol. I can't imagine anyone will ever need to collapse the hangouts option for just the current page they're on and then be content with them open as soon as they click something.
It's fine to have them showing all the time but the collapsing feature probably doesn't need to stay (or it should remember its state between pages) and the indentation should probably be refigured a bit......
 
OP
OP
Cerium

Cerium

General Manager
Administrator
Oct 23, 2017
752
Now there's one other recurring issue that I'm having, nothing major, but the forum doesn't seem to retain my decision to hide (not ignore) certain forum sections from the first page and with each refresh they're visible again. Before the toggle was removed and before it was ever implemented that was the one thing that stayed settled.

With that said, I should thank you again for resolving a lot of the other problems, admins. It definitely is appreciated.
Hello everyone. I have a problem whenever I Access the site from the laptop. The “Discussion” and “Official” sections are always closed whenever I return to the home page. No matter how many time I open, it closes again. On Safari
Yep, same and the browser is not remember my choices to keep them hidden
Information
This should now be fixed!
 

Queen Kong

Out of Kongtrol
Moderator
Oct 27, 2017
2,086
I have problem with the search bar, mobile, while browsing in threads. If you're at the middle of the thread and tries Search function, the keyboard keeps disappearing or you get scrolled up to the top.
I use Chrome.


With some attached images, you can't simply hold the image and copy the link. It pops up and zoom in (image below). Pressing back while in this mode will move you back a page, not zoom out like it should.
 
OP
OP
Cerium

Cerium

General Manager
Administrator
Oct 23, 2017
752
Am I imagining things, or are the "Hangouts" in the sidebar visible by default as of very recently?

Could they possibly be aligned to the right (text as well as icon) and not to the very left with no tab-space between the icon and the text? That looks visually confusing to me as it gives them the appearance of the important headline and not the less important sub-option.
Yeah, if anything they should have more indentation than the main categories.
Why aren't these aligned? It looks really poor.
So it is. In that case, leave the arrows as is (or change the collapsed one to an inward-pointing arrow). My main grievance is still the indentation and default/saved state of the collapsible areas -- I changed the arrows' directions mainly to address TI92's comment.
Information
We have adjusted the indentation of the Hangouts on the navigation. We are also exploring other ways to improve Hangouts visibility.
 
Oct 27, 2017
391
Information
We have adjusted the indentation of the Hangouts on the navigation. We are also exploring other ways to improve Hangouts visibility.
Thanks Cerium! Looks good on light theme, but the indentation still appears to be broken on dark theme. Also, at the risk of sounding nitpicky, the current Hangouts indentation is about half a character width, which doesn't really feel like enough to distinguish it from the other headings.
 
Oct 27, 2017
1,292
Information
We have adjusted the indentation of the Hangouts on the navigation. We are also exploring other ways to improve Hangouts visibility.
That's better. Could be intended a bit more (that's more a question of taste) and the vertical alignment is still a bit weird compared to their respective icons.