Why are embedded tweets not showing up lately?

ThisOne

Member
Oct 27, 2017
939
Lately (like the last 3-4 days), embedded tweets are not showing up for me on this site. I just get the Twitter logo and nothing else. Anyway to fix this or some setting that needs to be adjusted? Here's what it looks like:

 

Jag

Member
Oct 26, 2017
4,645
Your first issue is using light theme, but that doesn't have anything to do with Twitter.

More likely you have a blocker plugin that may have updated and is now blocking embeded tweets. uBlock, adblock, etc.
 

Tyaren

Member
Oct 25, 2017
7,395
I have that same issue for some weeks already too and I can't find the source. I don't even have adblock.
 

Dineren

The Fallen
Oct 25, 2017
1,677
Are you using Firefox? It has some builtin tracking blockers that might affect embeds. Not sure if that is the cause of your problem, but something to check.
 
OP
OP
ThisOne

ThisOne

Member
Oct 27, 2017
939
Oh, you want to know what? The mention of Adblock did actually make me remember that I recently set DuckDuckGo as my default search engine in Chrome. I think the DuckDuckGo is what's causing the issue with embedded tweets.
 

chalkitdown

Member
Oct 26, 2017
1,499
Embedded anything has always been a problem for me on mobile. It's potluck as to whether they work or not, that goes for Youtube, Twitter and Imgur.
 

Shevek

Member
Oct 25, 2017
821
Cape Town, South Africa
Are you using Firefox? It has some builtin tracking blockers that might affect embeds. Not sure if that is the cause of your problem, but something to check.
Yep, I had this exact issue recently and found that it was DuckDuckGo that had automatically installed and activated an addon called 'DuckDuckGo Privacy Essentials'. After disabling that, embedded tweets were displaying again.

Might want to check this OP
 

Joshua

Member
Oct 27, 2017
386
On mobile once I whitelisted Era in my ad blocker I never have an issue seeing embedded media including Tweets.