• iOS/Safari issues when launching the site from mobile home screens should now be fixed! A2HS button compatibility on Android Firefox has also been fixed! Add some purple to your home screen today.

Windows 10 Insider build 17040 adds SDR white level control for HDR output

Oct 25, 2017
1,492
Msk / SPb, Russia
#1
Adjust the brightness of SDR content on your HDR display: Starting with Build 17040, Windows now lets you adjust how bright SDR content appears when running in HDR mode on the desktop. On an HDR capable system, you will see a slider in the “HDR and advanced color settings” page under Settings > System > Display. This is one of the improvements to HDR image quality that we have planned based on feedback from Insiders.


This one was a long time in the making as MS should've added this control back in 1703 already but it should help in situations when turning on HDR in Windows results in a completely unusable desktop.

For those unaware of the issue, Windows 10 1703+ HDR mode renders everything SDR (which basically means all PC applications including the desktop itself and SDR games) with 100cd/m^2 brightness. Depending on where this brightness level is on your particular HDR screen it may result in SDR content being too dark, washed out or both.

This setting should help HDR users on PC to tweak the default system level of SDR white which in turn should make the desktop, applications and games a lot more usable in Windows 10 HDR mode on a wider number of HDR displays. Those of you who are using Insider builds and have issues with HDR in current Win10 release should check this one out.
 
OP
OP
dgrdsv
Oct 25, 2017
1,492
Msk / SPb, Russia
#8
The typical way of making it work post-1703 update is:
- Make sure that your GPU driver is running on default output color settings _or_ setup them yourself properly (you need 10 bits, 4:2:2 and limited for HDR10 @ 4K @ 60Hz; 12 bits and same for Dolby Vision)
- Turn HDR on in Windows display settings
- Launch the game and make sure that it's running in borderless windowed mode (or any mode really which isn't exclusive fullscreen*)
- Turn HDR on in game's settings if it hasn't turned on automatically

* - theoretically fullscreen enhancements should make this automatic but sometimes they don't.

If this doesn't work then there's some s/w problem.
 
Oct 25, 2017
21
#9
I guess that's better than nothing. Still, text doesn't render properly on desktop applications on any of my HDR displays when HDR is enabled, and I'm afraid being able to tweak the "dynamic range white level" won't fix that.

In any case, I wish they'd just go back to dealing with HDR content on a per application/game basis. I can only speak for myself, but I have absolutely no need for an HDR-enabled desktop at this time.
 
OP
OP
dgrdsv
Oct 25, 2017
1,492
Msk / SPb, Russia
#11
In any case, I wish they'd just go back to dealing with HDR content on a per application/game basis. I can only speak for myself, but I have absolutely no need for an HDR-enabled desktop at this time.
It's inevitable that the desktop will have to support HDR. Both YouTube and Vimeo provide HDR videos now, for example, and if you want to view them inside your browser with HDR being active you'll need it to work in DWM.

As for the text issues these are probably because of 4:2:2 chroma which is a limitation of HDMI 2.0 interface.
 
Oct 25, 2017
21
#12
It's inevitable that the desktop will have to support HDR. Both YouTube and Vimeo provide HDR videos now, for example, and if you want to view them inside your browser with HDR being active you'll need it to work in DWM.

As for the text issues these are probably because of 4:2:2 chroma which is a limitation of HDMI 2.0 interface.
Absolutely, that's where all of this is going eventually. I just feel that the way Windows 10 handles HDR currently is more of a hindrance than a benefit to me personally, so I've just disabled it altogether for now.

With any luck we'll have this sorted out within the next couple of years with HDMI 2.1-capable displays, video cards, etc.
 
Oct 27, 2017
37
#14
Sorry for the thread bump, but how do I enable this? I have MadVR and MPC-BE all set up.
In MPC-BE:
Settings > Video > Video renderer > select madVR.
Then go to external filters tab, disable ffdshow raw video filter, click add filter, select madVR and set it as preferred.

In madVR:
devices > [your device] > hdr > select let madVR decide
 
Oct 25, 2017
18,400
#15
In MPC-BE:
Settings > Video > Video renderer > select madVR.
Then go to external filters tab, disable ffdshow raw video filter, click add filter, select madVR and set it as preferred.

In madVR:
devices > [your device] > hdr > select let madVR decide
In my external filters tab it's just LAV audio and video decoder?

Also, it had HDR > Let MadVR decide selected as default but when I watched a video earlier it didn't enable HDR, but it did when I tried to watch it direct from my TV

Thanks though :)
 
Oct 27, 2017
37
#16
In my external filters tab it's just LAV audio and video decoder?

Also, it had HDR > Let MadVR decide selected as default but when I watched a video earlier it didn't enable HDR, but it did when I tried to watch it direct from my TV

Thanks though :)
Well, i just mentioned this because ffdshow raw video filter blocks madVR HDR passthrough, but if you don't have it, that's ok.
However, you still need to add madVR as external filter and set it to preferred.
 
Last edited:
Oct 25, 2017
18,400
#17
Well, i just mentioned this because ffdshow raw video filter blocks madVR HDR passthrough, but if you don't have it, that's ok.
However, you still need to add madVR as external filter and set it to preferred.

ALSO, you might want to do first two steps from post #8, although it shouldn't be necessary with latest graphic drivers and madVR build
Done :) Do I need to enable HDR in windows settings, or will MadVR do that? Just it makes the desktop washed out, thanks again
 
Oct 27, 2017
37
#18
Done :) Do I need to enable HDR in windows settings, or will MadVR do that? Just it makes the desktop washed out, thanks again
You can, since i find OS HDR to be more reliable then AMD/Nvidia (just make sure to use default output color settings in control panel.), although it shouldn't be necessary with latest graphic drivers and madVR build.

Basically, if you enable hdr in windows, madVR will use OS HDR, but if you don't, it will use graphic driver HDR
 
Oct 25, 2017
18,400
#19
You can, since i find OS HDR to be more reliable then AMD/Nvidia (just make sure to use default output color settings in control panel.), although it shouldn't be necessary with latest graphic drivers and madVR build.

Basically, if you enable hdr in windows, madVR will use OS HDR, but if you don't, it will use graphic driver HDR
Thanks a lot for your help :D I didn't even know about NVIDIA having support for HDR without the need for enabling it in Windows Settings.

1 final question, if I don't enable it in settings but play the video, will my TV display the HDR logo to let me know its in HDR or not? as it usually does when I play HDR content direct from a USB/Youtube/Netflix app etc
 

D65

Banned
Member
Oct 26, 2017
6,862
#20
People are going to blind themselves



--

also I only recently discovered that you can enable HDR for extended displays only. It's a god send.
 
Oct 27, 2017
37
#21
Thanks a lot for your help :D I didn't even know about NVIDIA having support for HDR without the need for enabling it in Windows Settings.

1 final question, if I don't enable it in settings but play the video, will my TV display the HDR logo to let me know its in HDR or not? as it usually does when I play HDR content direct from a USB/Youtube/Netflix app etc
It should, since it basically signals that TV is now in HDR mode
 
Oct 25, 2017
1,839
#22
I have am issue with Hitman where on default color settings the game says I don't have a HDR capable tv (own LG c7), so I get no HDR availability in game. I'll try with 422 settings later tonight.
 
Oct 25, 2017
1,637
#23
Thank God

I switch from an HDR TV to a non HDR 21:9 monitor and Everytime I would load a non HDR game on the TV it was a complete crapshoot if it would display properly or get all fucked up and washed out.

FFXIV was fine, then it wasn't, then I toggled AA to off, and it was fixed, then switched back to my monitor, and then back to the TV and no setting would get it to display the proper SDR brightness value. It was always washed out no matter the setting.
 
Oct 27, 2017
37
#24
I have am issue with Hitman where on default color settings the game says I don't have a HDR capable tv (own LG c7), so I get no HDR availability in game. I'll try with 422 settings later tonight.
Do this:
The typical way of making it work post-1703 update is:
- Make sure that your GPU driver is running on default output color settings _or_ setup them yourself properly (you need 10 bits, 4:2:2 and limited for HDR10 @ 4K @ 60Hz; 12 bits and same for Dolby Vision)
- Turn HDR on in Windows display settings
- Launch the game and make sure that it's running in borderless windowed mode (or any mode really which isn't exclusive fullscreen*)
- Turn HDR on in game's settings if it hasn't turned on automatically
This applies to every game that uses windows HDR
 
Oct 31, 2017
1,819
#29
True story: the last Windows 10 update killed my office PC and almost costed us a lot of invaluable data we didn't backup in time (records of all the subscribers to our gym in the last 6 months).
In the end I managed to salvage what was really important by connecting my HD to another PC and copying few folders directly.
But I had to format that HD for any chance of it to work again as a boot drive.

Important lesson I learned out of this:
- never assume online stories about Windows updates fucking up things are a myth
- always back up your important data, as a general good rule and especially before updating Windows.
 
Oct 27, 2017
3,500
#30
Oh my MadVR is 0.92.10, how do I update it?

GPU is fully updated, as is Windows
You can actually just delete the madVR folder and replace it with the new one. That's what I ended up doing, and it gave me the HDR option. It's not in the "external filter" setting either. It's under the first tab, which is "devices" that shows the current monitor you're using. Expand that, and at the bottom you should have an HDR option to tick. Edit the options by opening up madVR while it's running. Don't do it through KCP or whatever if that's what you're using as a package.

edit: Not sure how the version numbers work with madVR, but 0.92.9 works, so I'm assuming that's simply a "9" and not a "90". So you should already have the version that works. It also seems to be more reliable to simply set it to "passthrough HDR content to the display".
 
Last edited:
Oct 27, 2017
37
#31
Oh my MadVR is 0.92.10, how do I update it?

GPU is fully updated, as is Windows
You can always download latest version form here, then just copy & paste in install directory.

Also, try disabling automatic fullscreen exclusive mode in madVR (rendering > general settings)
 
Last edited:
Oct 25, 2017
18,400
#32
Do you have latest drivers (390.65) and madVR build (0.92.11)?
Think/Hoping it's sorted :) HDR doesn't come up in the corner but color looks different when I go fullscreen in MPC compared to windowed

EDIT: Enabled HDR in windows settings and played a file, went fullscreen and its still dark and washed out. Damn.
 
Oct 27, 2017
3,500
#33
Think/Hoping it's sorted :) HDR doesn't come up in the corner but color looks different when I go fullscreen in MPC compared to windowed

EDIT: Enabled HDR in windows settings and played a file, went fullscreen and its still dark and washed out. Damn.
Ignore the Windows setting for now (you might need to reconsider later with the next update however). Keep it off and set it up in madVR to passthrough HDR to the TV. Make sure the "send metadata to the TV" box at the bottom is checked too.

 
Oct 25, 2017
18,400
#36
Ignore the Windows setting for now (you might need to reconsider later with the next update however). Keep it off and set it up in madVR to passthrough HDR to the TV. Make sure the "send metadata to the TV" box at the bottom is checked too.

Still no HDR logo in the corner of my TV :(

Image looks better in fullscreen and when I go back to windowed the picture is more washed out, but I don't know if it's HDR in fullscreen or if it's making it SDR so it isn't washed out
 
Oct 27, 2017
37
#38
Still no HDR logo in the corner of my TV :(

Image looks better in fullscreen and when I go back to windowed the picture is more washed out, but I don't know if it's HDR in fullscreen or if it's making it SDR so it isn't washed out
Try playing the same file directly from TV, see how colors and highlights look compared to MPC, if they look about the same, it means that MPC and madVR are working correctly
 
Oct 25, 2017
18,400
#39
Try playing the same file directly from TV, see how colors and highlights look compared to MPC, if they look about the same, it means that MPC and madVR are working correctly
Yeah, HDR definitely isn't working for me :(



Colours a lot nicer direct from TV. Oh well.

HDR support on Windows is terrible imo, ffs Microsoft.
 
OP
OP
dgrdsv
Oct 25, 2017
1,492
Msk / SPb, Russia
#42
Can anyone explain to me why HDR is handled by the OS and not by the video drivers like any other graphical option?
What do you mean? HDR is a display mode and it's an OS task to request and support any display mode. Driver is only providing the interface through which the OS can access some mode of the h/w.

That being said, I've seen reports that the latest 390.65 driver has fully restored NVAPI HDR support in both 1703 and 1709.
 
Nov 24, 2017
454
Kent
#43
Yeah, Andromeda still doesn't work. Tried exactly as stated above and nope. Obviously an issue with the game but as it's no longer being supported it'll never be fixed.